mydevices and guesthelp web portals are down
Incident Report for CIT Geneseo Status
Resolved
Our mydevices and guesthelp portals are operational now. Thank you for your patience with this.

The mydevices portal looks different than in the past, but all functionality is present.
Posted Mar 22, 2023 - 09:04 EDT
Identified
Our vendor has identified the issue and has given us a workaround to restore service. The portals are operational now and users can register devices to gPlay. We hope to have a permanent fix in place by the end of the day tomorrow.
Posted Mar 20, 2023 - 16:03 EDT
Update
We are still working with the vendor to identify the problem and resolve the issue. We have determined that if we uninstall a critical security patch the portals become active again. However, we need the security patch installed to address several critical vulnerabilities and thus we cannot simply roll back to restore portal functionality. We have provided this information to the vendor and they are continuing to troubleshoot the issue.
Posted Mar 20, 2023 - 10:39 EDT
Update
We just discovered that the "geneseo guest" wifi portal is also broken.
We do not have an estimate of time to resolution yet.
We are working with our vendor.
Posted Mar 17, 2023 - 12:54 EDT
Investigating
The mydevices.geneseo.edu and guesthelp.geneseo.edu web portals are down. We currently have a service request open with the vendor to troubleshoot and fix. Users will not be able to register new devices to the gPlay network until this is resolved. Devices that were already registered will continue to work.
Posted Mar 17, 2023 - 12:27 EDT
This incident affected: Network & Wireless (Wireless Connectivity).