Intermittent WiFi Access/Authentication Issues

Incident Report for CIT Geneseo Status

Resolved

Lingering wifi connection issues have ended. We resynchronized our wifi authentication systems and that seems to have resolved the issue.
Posted Mar 05, 2026 - 15:28 EST

Investigating

We are investigating intermittent issues with people connecting to the wireless network.
Posted Mar 04, 2026 - 12:31 EST
This incident affected: Network & Wireless (Wireless Connectivity).