Docuware issues
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 09:17 EDT
Investigating
We are investigating issues with the Docuware database that may impact availability.
Posted Mar 24, 2023 - 08:38 EDT
This incident affected: Administrative Systems (Docuware).