Jira Email Processing Outage

Incident Report for CIT Geneseo Status

Resolved

Atlassian has identified an internal issue and applied a fix to mitigate it, so email processing issues are now resolved. Since the issue was with authentication, emails not processed during the outage should now be caught up. https://developer.status.atlassian.com/incidents/7dp5zv6byqgd
Posted Oct 12, 2025 - 15:17 EDT

Identified

We have discovered the cause of the issue is an inability for Jira to retrieve OAUTH tokens from Google. Jira support suggested deleting and re-adding the email addresses used for email correspondence with our service desks. This resolved the issue temporarily, but the same problem has come back within an hour or two. We have opened support requests with Atlassian and Google to investigate further.
Posted Oct 12, 2025 - 13:20 EDT

Investigating

We have received reports that emails to Jira Service Desks are not being processed. We are investigating the issue now.
Posted Oct 12, 2025 - 11:02 EDT
This incident affected: Campus Services (help.geneseo.edu (JIRA)).