Guest WiFi Outage
Incident Report for CIT Geneseo Status
Resolved
We have reworked the geneseo guest WiFi to avoid the portal issue that was at the root of this issue. The geneseo guest WiFi network is now working properly.
Posted May 24, 2023 - 11:14 EDT
Update
We are still working on this issue. We are opening a service request with our WiFi vendor. We apologize for any inconveniences this may cause.
Posted May 24, 2023 - 08:53 EDT
Investigating
Guest Wireless access is currently unavailable. We are investigating the issue now, but there is currently no ETA on resolution.
Posted May 22, 2023 - 13:04 EDT
This incident affected: Network & Wireless (Wireless Connectivity).