CIT Self Help Outage
Incident Report for CIT Geneseo Status
Resolved
The issue causing the 502 Bad Gateway errors when attempting to connect to CIT Self Help has been resolved and the service is now operating normally.
Posted Mar 26, 2024 - 14:26 EDT
Investigating
Attempted connections to the CIT Self Help site are currently met with a 502 Bad Gateway error. We are investigating the problem now.
Posted Mar 26, 2024 - 09:53 EDT
This incident affected: Campus Services (help.geneseo.edu (JIRA)).