Thrid Floor Seneca Switch Down

Incident Report for CIT Geneseo Status

Resolved

The issue has been resolved.
Posted Nov 26, 2025 - 11:28 EST

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 11:27 EST

Investigating

We are investigating a switch that went down on the third floor in Seneca. Currently there is no wired connection and partial wireless connection on the third floor.
Posted Nov 26, 2025 - 10:26 EST
This incident affected: Network & Wireless (Residence Hall Wired Connectivity, Wireless Connectivity).