Banner Admin Pages intermittent connection issues
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Jul 15, 2021 - 12:15 EDT
Investigating
Currently researching Banner Admin Pages intermittent connection issues
Posted Jul 15, 2021 - 12:15 EDT
This incident affected: Administrative Systems (Banner).