Appworx unavailable

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 08:52 EDT

Monitoring

Appworx Banner database connections are now functioning. We will continue to monitor.
Posted Mar 18, 2026 - 08:22 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 08:08 EDT

Update

ITEC has identified the problem and is working on a fix. Appworx should be operational shortly.
Posted Mar 18, 2026 - 08:07 EDT

Investigating

The Appworx environment remains unable to connect to the Banner database following the ITEC network maintenance earlier this morning. We are working with ITEC to resolve.
Posted Mar 18, 2026 - 06:45 EDT
This incident affected: Administrative Systems (AppWorx).