Automated Telephone Operator Outage

Incident Report for CIT Geneseo Status

Resolved

The automated telephone operator is operational and the issues have been fully resolved.
Posted Sep 05, 2025 - 12:19 EDT

Update

We are still preparing to implement the solution with our vendor.
Posted Sep 04, 2025 - 16:08 EDT

Update

We have identified a solution to the issue and we are working with our vendor to begin implementing it. We will have another update by 4:00pm.
Posted Sep 04, 2025 - 14:28 EDT

Update

We are working with our vendor on replacing the automated telephone operator. The system is still down. We will have another update by 2:00pm.
Posted Sep 04, 2025 - 11:30 EDT

Investigating

Our automated telephone operator is currently down. We are working with the vendor to resolve the issue. We will have an update by 11:00am.
Posted Sep 04, 2025 - 08:49 EDT
This incident affected: Campus Services (Telephone Services).