Credit card processing network off-line

Incident Report for CIT Geneseo Status

Resolved

Credit card network connectivity has been restored.
Posted Feb 12, 2025 - 08:55 EST

Investigating

We are beginning to investigate a report that our credit card processing network is off line. More details by 8:45 am.
Posted Feb 12, 2025 - 08:05 EST
This incident affected: Network & Wireless (PCI Network).